fix some errors

parent 1c31982a
......@@ -50,15 +50,7 @@ class base::ipmi (
# For Debian 8+, the package brings in everything it needs by
# default. But, if we are re-enabling we need to recover a file that
# we deleted. We then have to trigger systemd to load modules.
if ($::puppetversion =~ /^3/) {
$operatingsystem = $::operatingsystem
$lsdbmajdistrelease = $::lsdbmajdistrelease
} else {
$operatingsystem = $facts['os']['name']
$lsdbmajdistrelease = Integer($facts['os']['release']['major'])
}
if (($operatingsystem == 'Debian') and ($lsdbmajdistrelease >= 8)) {
if (($::operatingsystem == 'Debian') and ($::lsdbmajdistrelease >= 8)) {
exec { 'Re-create /usr/lib/modules-load.d/ipmievd.conf':
command => '/usr/bin/apt-get install --reinstall ipmitool',
creates => '/usr/lib/modules-load.d/ipmievd.conf',
......
......@@ -6,14 +6,8 @@ class base::pam::debian {
package { 'libpam-krb5': ensure => present }
package { 'libpam-afs-session': ensure => present }
if ($::puppetversion =~ /^3/) {
$lsdbmajdistrelease = $::lsdbmajdistrelease
} else {
$lsdbmajdistrelease = Integer($facts['os']['release']['major'])
}
# Starting with Debian jessie, pam-auth-update manages the common PAM files.
if ($lsdbmajdistrelease < 8) {
if ($::lsdbmajdistrelease < 8) {
file {
'/etc/pam.d/common-auth':
source => 'puppet:///modules/base/pam/etc/pam.d/common-auth',
......
......@@ -136,8 +136,8 @@ MaxSessions <%= @max_sessions %>
# we have to configure the authentications for root separately.
<%-
gssapi_only = ['root', 'root.*', '*.root', 'admin.*', '*.admin']
gssapi_only = admin_users + @extra_gssapi_only_users
gssapi_only_list = admin_users.join(',')
gssapi_only = gssapi_only + @extra_gssapi_only_users
gssapi_only_list = gssapi_only.join(',')
-%>
Match User <%= gssapi_only_list %>
AuthenticationMethods gssapi-with-mic
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment