Commit 227b2024 authored by Jonathan Lent's avatar Jonathan Lent

Slight fix for release 004.046 (rpm.pp)

parent 01682427
......@@ -88,13 +88,13 @@ class base::rpm {
# RHEL systems need this plugin enabled, due to new licensing
if ($::operatingsystem == 'RedHat') {
# enable yum rhn plugin
exec { 'enable yum rhn plugin':
exec { 'yum rhn plugin':
command => "perl -pe 's/enabled = 0/enabled = 1/' -i /etc/yum/pluginconf.d/rhnplugin.conf",
onlyif => "[ -e /etc/yum/pluginconf.d/rhnplugin.conf ] && grep -q 'enabled = 0' /etc/yum/pluginconf.d/rhnplugin.conf",
}
} else {
# disable yum rhn plugin
exec { 'disable yum rhn plugin':
exec { 'yum rhn plugin':
command => "perl -pe 's/enabled = 1/enabled = 0/' -i /etc/yum/pluginconf.d/rhnplugin.conf",
onlyif => "[ -e /etc/yum/pluginconf.d/rhnplugin.conf ] && grep -q 'enabled = 1' /etc/yum/pluginconf.d/rhnplugin.conf",
}
......@@ -104,7 +104,7 @@ class base::rpm {
exec { 'enable yum plugins':
command => "perl -pe 's/plugins=0/plugins=1/' -i /etc/yum.conf",
onlyif => "grep -q 'plugins=0' /etc/yum.conf",
require => Exec['disable yum rhn plugin'],
require => Exec['yum rhn plugin'],
}
}
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment